Intermittent Call Issues

Incident Report for MightyCall

Resolved

This incident has been resolved.
Posted Mar 22, 2025 - 17:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2025 - 17:11 UTC

Identified

We're currently having intermittent call issues due to a local incident. The incident have been identified, and it's being currently worked on. We will keep our customers updated of any developments.
Posted Mar 22, 2025 - 16:48 UTC
This incident affected: Calls (Webphone, MobileApp, Deskphone).