The issue with inbound/outbound calls experienced by some users has been fully resolved. All services are now operating normally.
We appreciate your patience while our team worked to address and resolve the problem.
Posted Nov 04, 2025 - 20:36 UTC
Monitoring
A fix has been successfully deployed to resolve the inbound/outbound call issues and delays. We're currently monitoring the platform closely to ensure stability. If you experience any further delays or issues with inbound/outbound calls, please reach out to our support team. A final update will follow, once the issue is fully confirmed as resolved.
Posted Nov 04, 2025 - 19:49 UTC
Identified
We have identified the root cause of the issue affecting inbound call queues and visibility delays, along with intermittent outbound call failures. Our team is actively working on applying a fix to restore the normal functionality. We'll share another update once the fix has been deployed.
Posted Nov 04, 2025 - 16:59 UTC
Investigating
We're currently investigating the issue with inbound calls getting queued and displayed with delays for some users. There have also been intermittent reports of outbound call failures. Our team is working to identify the root cause and restore normal operation as soon as possible.
Posted Nov 04, 2025 - 16:42 UTC
This incident affected: Calls (Webphone) and Front-End (Web Panel).