Local Numbers Availability Issues
Incident Report for MightyCall
Resolved
This incident has been resolved.
Posted May 18, 2022 - 03:03 UTC
Investigating
We are currently investigating this issue.
Posted May 18, 2022 - 02:19 UTC