Calls via Deskphones Issues

Incident Report for MightyCall

Resolved

This incident has been resolved.
Posted Jun 24, 2022 - 10:08 UTC

Investigating

We are currently investigating this issue.
Posted Jun 24, 2022 - 10:06 UTC