Local Numbers Availability Issues
Incident Report for MightyCall
Resolved
This incident has been resolved.
Posted Jun 26, 2022 - 04:49 UTC
Investigating
We are currently investigating this issue.
Posted Jun 26, 2022 - 04:40 UTC