Inbound/Outbound Call Issues
Incident Report for MightyCall
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 22:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2024 - 22:24 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 13, 2024 - 22:07 UTC
Update
We are continuing to investigate this issue.
Posted Nov 13, 2024 - 21:43 UTC
Update
We are continuing to investigate this issue.
Posted Nov 13, 2024 - 21:21 UTC
Investigating
We're currently investigating the issue with inbound & outbound calls. The issue has been escalated to the upstream carrier, we're working together to resolve it as soon as possible.
Posted Nov 13, 2024 - 21:20 UTC
This incident affected: Calls (Webphone, MobileApp, Deskphone).